PresentationProps Interface
Properties that can be used to configure Presentation API.
Extends
- Omit<PresentationManagerProps, "enableSchemasPreload">
Properties
Name | Type | Description | |
---|---|---|---|
enableSchemasPreload | boolean | undefined | Should schemas preloading be enabled. | |
requestTimeout | number | undefined | Time in milliseconds after which the request will timeout. | |
unusedClientLifetime | number | undefined | How much time should an unused client manager be stored in memory |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
caching Inherited | PresentationManagerCachingConfig | undefined | Omit | Options for caching. |
defaultFormats Inherited | FormatsMap | undefined | Omit | A map of default unit formats to use for formatting properties that don't have a presentation format |
defaultLocale Inherited | string | undefined | Omit | Sets the active locale to use when localizing presentation-related |
defaultUnitSystem Inherited | UnitSystemKey | undefined | Omit | Sets the active unit system to use for formatting property values with |
diagnostics Inherited | BackendDiagnosticsOptions<any> | undefined | Omit | Parameters for gathering diagnostics at the manager level. |
getLocalizedString Inherited | (key: string) => string | undefined | Omit | Localization function to localize data returned by presentation manager when it's used directly on the backend (as opposed to when used through RPC, where |
localeDirectories Inherited | string[] | undefined | Omit | A list of directories containing application's locale-specific localized |
mode Inherited | PresentationManagerMode | undefined | Omit | Presentation manager working mode. |
presentationAssetsRoot Inherited | string | PresentationAssetsRootConfig | Omit | Path overrides for presentation backend assets. |
rulesetDirectories Inherited | string[] | undefined | Omit | A list of directories containing application's presentation rulesets. |
schemaContextProvider Inherited | (imodel: IModelDb) => SchemaContext | undefined | Omit | Callback that provides SchemaContext for supplied IModelDb. |
supplementalRulesetDirectories Inherited | string[] | undefined | Omit | A list of directories containing application's supplemental presentation rulesets. |
updatesPollInterval Inherited | number | undefined | Omit | The interval (in milliseconds) used to poll for presentation data changes. |
useMmap Inherited | number | boolean | Omit | Use SQLite's Memory-Mapped I/O for worker connections. |
workerThreadsCount Inherited | number | undefined | Omit | A number of worker threads to use for handling presentation requests. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.