BackendDiagnosticsOptions<TContext> Interface
Data structure for backend diagnostics options.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
handler | BackendDiagnosticsHandler<TContext> | Request diagnostics handler function that is called after the request is fulfilled. | |
requestContextSupplier | () => TContext | undefined | An optional function to supply request context that'll be passed to handler when |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
dev Inherited | boolean | DiagnosticsLoggerSeverity | DiagnosticsOptions | Severity for developer log messages |
editor Inherited | boolean | DiagnosticsLoggerSeverity | DiagnosticsOptions | Severity for presentation rules' editor log messages |
perf Inherited | boolean | { minimumDuration: number } | DiagnosticsOptions | Flag specifying that performance should be measured, or |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.