Presentation Class
Static class used to statically set up Presentation library for the backend. Basically what it does is:
- Register a RPC implementation
- Create a singleton PresentationManager instance
- Subscribe for IModelHost.onBeforeShutdown event and terminate the presentation manager when that happens.
Methods
Name | Description | |
---|---|---|
getManager(clientId?: string): PresentationManager Static | Get an instance of PresentationManager for specific client | |
getRequestTimeout(): number Static | Get the time in milliseconds that backend should respond in . | |
initialize(props?: PresentationProps): void Static | Initializes Presentation library for the backend. | |
terminate(): void Static | Terminates Presentation. |
Properties
Name | Type | Description | |
---|---|---|---|
initProps Accessor Static ReadOnly | undefined | PresentationProps | Properties used to initialize the presentation framework |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.