getPagedDistinctValues Method
Retrieves distinct values of specific field from the content based on the supplied content descriptor override.
getPagedDistinctValues(requestOptions: DistinctValuesRequestOptions<IModelDb, Descriptor | DescriptorOverrides, KeySet, RulesetVariable> & { priority?: number } & { cancelEvent?: BeEvent<() => void> } & BackendDiagnosticsAttribute): Promise<PagedResponse<DisplayValueGroup>>
@returns A promise object that returns either distinct values on success or an error string on error.
Parameter | Type | Description |
---|---|---|
requestOptions | DistinctValuesRequestOptions<IModelDb, Descriptor | DescriptorOverrides, KeySet, RulesetVariable> & { priority?: number } & { cancelEvent?: BeEvent<() => void> } & BackendDiagnosticsAttribute | Options for the request |
Returns - Promise<PagedResponse<DisplayValueGroup>>
A promise object that returns either distinct values on success or an error string on error.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.