getNodePaths Method
Retrieves paths from root nodes to children nodes according to specified instance key paths. Intersecting paths will be merged. TODO: Return results in pages
getNodePaths(requestOptions: FilterByInstancePathsHierarchyRequestOptions<IModelDb, RulesetVariable> & { priority?: number } & { cancelEvent?: BeEvent<() => void> } & BackendDiagnosticsAttribute): Promise<NodePathElement[]>
Parameter | Type | Description |
---|---|---|
requestOptions | FilterByInstancePathsHierarchyRequestOptions<IModelDb, RulesetVariable> & { priority?: number } & { cancelEvent?: BeEvent<() => void> } & BackendDiagnosticsAttribute |
Returns - Promise<NodePathElement[]>
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.