FilterByInstancePathsHierarchyRequestOptions<TIModel, TRulesetVariable> Interface
Request type of filtering hierarchies by given ECInstance paths.
Extends
- RequestOptionsWithRuleset<TIModel, TRulesetVariable>
Properties
Name | Type | Description | |
---|---|---|---|
instancePaths | InstanceKey[][] | A list of paths from root ECInstance to target ECInstance. | |
markedIndex | number | undefined | An optional index (0 <= markedIndex < instancePaths.length ) to mark one of the instance paths. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
imodel Inherited | TIModel | RequestOptionsWithRuleset<TIModel, TRulesetVariable> | iModel to request data from |
locale Inherited | string | undefined | RequestOptionsWithRuleset<TIModel, TRulesetVariable> | Optional locale to use when formatting / localizing data |
rulesetOrId Inherited | string | Ruleset | RequestOptionsWithRuleset<TIModel, TRulesetVariable> | Ruleset or id of the ruleset to use when requesting data |
rulesetVariables Inherited | TRulesetVariable[] | undefined | RequestOptionsWithRuleset<TIModel, TRulesetVariable> | Ruleset variables to use when requesting data |
unitSystem Inherited | UnitSystemKey | undefined | RequestOptionsWithRuleset<TIModel, TRulesetVariable> | Unit system to use when formatting property values with units. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.