RequestOptionsWithRuleset<TIModel, TRulesetVariable> Interface
Options for requests that require presentation ruleset. Not meant to be used directly, see one of the subclasses.
Extends
- RequestOptions<TIModel>
Properties
Name | Type | Description | |
---|---|---|---|
rulesetOrId | string | Ruleset | Ruleset or id of the ruleset to use when requesting data | |
rulesetVariables | TRulesetVariable[] | undefined | Ruleset variables to use when requesting data |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
imodel Inherited | TIModel | RequestOptions<TIModel> | iModel to request data from |
locale Inherited | string | undefined | RequestOptions<TIModel> | Optional locale to use when formatting / localizing data |
unitSystem Inherited | UnitSystemKey | undefined | RequestOptions<TIModel> | Unit system to use when formatting property values with units. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.