getFromToLocations MethodStatic
Query for LinearlyReferenced FromToLocation aspects owned by the specified LinearlyLocated Element.
getFromToLocations(iModel: IModelDb, linearlyLocatedElementId: string): LinearlyReferencedFromToLocation[]
@returns Returns an array of LinearlyReferencedFromToLocation.
@throws IModelError
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | The iModel to query from. |
linearlyLocatedElementId | string | The id of the LinearlyLocated Element to query aspects about. |
Returns - LinearlyReferencedFromToLocation[]
Returns an array of LinearlyReferencedFromToLocation.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.