SectionMarkerSet Class
A MarkerSet containing SectionMarkers identifying SectionDrawingLocations within a spatial view. Typically used indirectly via HyperModelingDecorator.
Extends
Methods
Name | Description | |
---|---|---|
constructor(viewport: ScreenViewport, markers: SectionMarker[]): SectionMarkerSet | Constructor | |
findMarkerById(sectionDrawingLocationId: string): undefined | SectionMarker | Find the SectionMarker corresponding to the specified SectionDrawingLocation Id. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
addDecoration(context: DecorateContext): void Inherited | MarkerSet | This method should be called from Decorator.decorate. |
changeViewport(viewport: ScreenViewport): void Inherited | MarkerSet | Change the ScreenViewport for this MarkerSet. |
getMinScaleViewW(vp: Viewport): number Inherited | MarkerSet | Get weight value limit establishing the distance from camera for the back of view scale factor. |
markDirty(): void Inherited | MarkerSet | Indicate that this MarkerSet has been changed and is now dirty. |
Properties
Name | Type | Description | |
---|---|---|---|
minimumClusterSize | number | The minimum number of Markers that must overlap before they are clustered. | |
viewport Accessor ReadOnly | ScreenViewport | The viewport in which the markers are to be displayed. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
clusterRadius Protected Inherited | number | MarkerSet | The radius (in pixels) representing the distance between the screen X,Y positions of two Markers to be clustered. |
markers Accessor Inherited ReadOnly | Set<MarkerSet.T> | MarkerSet | The set of Markers in this MarkerSet. Add your Markers into this. |
Defined in
- hypermodeling/src/SectionMarkers.ts Line 169
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.