isMarkerVisible Method
Customize which markers are visible. HyperModelingDecorator determines marker visibility as follows:
- If a marker is currently active (selected), only that marker is visible.
- Otherwise, the marker is visible if this method returns
true
. The default implementation of this method determines visibility based on the SectionMarkerConfig as follows. - If the marker is of a type included in the config's
hiddenSectionTypes
, it is invisible. - If the marker belongs to a model not currently displayed in the viewport and the config's
ignoreModelSelector
is false, it is invisible. - If the marker belongs to a category not currently displayed in the viewport and the config's
ignoreCategorySelector
is false, it is invisible, - Otherwise, the marker is visible, unless this method returns
false
. The default implementation of this method always returnstrue
isMarkerVisible(marker: SectionMarker, decorator: HyperModelingDecorator, config: SectionMarkerConfig): boolean
@returns true if the marker should be displayed; false to make it invisible.
@see requestSync to force the decorator to reevaluate marker visibility when the criterion used by your implementation of this method changes.
Parameter | Type | Description |
---|---|---|
marker | SectionMarker | The marker whose visibility is to be determined. |
decorator | HyperModelingDecorator | The hypermodeling decorator to which the marker belongs. |
config | SectionMarkerConfig | The configuration controlling marker visibility based on SectionType, ModelSelectorState, and CategorySelectorState. |
Returns - boolean
true if the marker should be displayed; false to make it invisible.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.