SectionMarkerConfig Interface
Configures display of SectionMarkers for HyperModelingDecorators.
@see - updateConfiguration or replaceConfiguration to change the configuration for a specific decorator.
- initialize to set the default configuration for all decorators at package initialization.
- updateConfiguration or replaceConfiguration to change the default configuration for all subsequently created decorators.
- HyperModelingConfig.
Properties
Name | Type | Description | |
---|---|---|---|
hiddenSectionTypes Readonly | SectionType[] | undefined | A list of types of section markers that shouold not be displayed. | |
ignoreCategorySelector Readonly | boolean | undefined | Whether to hide markers belonging to categories that are not present in the view's CategorySelector. | |
ignoreModelSelector Readonly | boolean | undefined | Whether to hide markers belonging to models that are not present in the view's ModelSelector. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.