SectionGraphicsConfig Interface
Configures how 2d graphics are displayed by a HyperModelingDecorator when hypermodeling is active. This configuration is used primarily for debugging, and applies globally to section graphics associated with all HyperModelingDecorators.
@see - initialize to set this configuration at package initialization.
- updateConfiguration or replaceConfiguration to change this configuration after package initialization.
- HyperModelingConfig.
Properties
Name | Type | Description | |
---|---|---|---|
debugClipVolumes Readonly | boolean | undefined | If true, clip volumes for 2d graphics are displayed as shapes. | |
hideSectionGraphics Readonly | boolean | undefined | If true, SectionDrawing graphics will not be displayed. | |
hideSheetAnnotations Readonly | boolean | undefined | If true, Sheet annotation graphics will not be displayed. | |
ignoreClip Readonly | boolean | undefined | If true, 2d graphics will not be clipped. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.