AttachMapLayerTool Class

This tool add a Map Layer from a specified name (look up in MapLayerSources.json).

Extends

  • AttachMapLayerBaseTool

Extended by

Methods

Name Description
constructor(_isBackground: booleantrue, _isBase: booleanfalse): AttachMapLayerTool    
parseAndRun(...args: string[]): Promise<boolean> Executes this tool's run method with args[0] containing name.  
run(name: string): Promise<boolean> This method runs the tool, adding a map layer from a specified name in MayLayerSources.json.  

Inherited methods

Name Inherited from Description
doAttach(source?: MapLayerSource): void Protected Inherited AttachMapLayerBaseTool  
register(namespace?: string): void Static Inherited AttachMapLayerBaseTool Register this Tool class with the ToolRegistry.

Properties

Name Type Description
maxArgs Accessor Static ReadOnly number The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum.  
minArgs Accessor Static ReadOnly number The minimum number of arguments allowed by parseAndRun.  
toolId Static string The unique string that identifies this tool.  

Inherited properties

Name Type Inherited from Description
_isBackground Protected Inherited boolean AttachMapLayerBaseTool  
_isBase Protected Inherited boolean AttachMapLayerBaseTool  
description Accessor Inherited ReadOnly string AttachMapLayerBaseTool Get the localized description string from this Tool's class
description Accessor Static Inherited ReadOnly string AttachMapLayerBaseTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
AttachMapLayerBaseTool.flyover is returned.
englishKeyin Accessor Static Inherited ReadOnly string AttachMapLayerBaseTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor Inherited ReadOnly string AttachMapLayerBaseTool Get the localized flyover string from this Tool's class
flyover Accessor Static Inherited ReadOnly string AttachMapLayerBaseTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
AttachMapLayerBaseTool.keyin is returned.
hidden Static Inherited boolean AttachMapLayerBaseTool If true, this Tool will not appear in the list from ToolRegistry.getToolList.
iconSpec Accessor Inherited ReadOnly string AttachMapLayerBaseTool Get the iconSpec from this Tool's class.
iconSpec Static Inherited string AttachMapLayerBaseTool The icon for this Tool.
keyin Accessor Inherited ReadOnly string AttachMapLayerBaseTool Get the localized keyin string from this Tool's class
keyin Accessor Static Inherited ReadOnly string AttachMapLayerBaseTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
namespace Static Inherited string AttachMapLayerBaseTool The namespace that provides localized strings for this Tool.
toolId Accessor Inherited ReadOnly string AttachMapLayerBaseTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.

Defined in

Last Updated: 14 November, 2024