ApplyRenderingStyleTool Class

Given a "rendering style" as a partial DisplayStyle3dSettingsProperties JSON string, apply it to the selected viewport's display style.

@see DisplayStyleSettings.applyOverrides for details.

Extends

Methods

Name Description
constructor(..._args: any[]): ApplyRenderingStyleTool    
execute(vp: Viewport): Promise<boolean>    
parse(args: string[]): Promise<boolean>    

Inherited methods

Name Inherited from Description
parseAndRun(...args: string[]): Promise<boolean> Inherited DisplayStyleTool Run this instance of a tool using a series of string arguments.
run(): Promise<boolean> Inherited DisplayStyleTool Run this instance of a Tool.
register(namespace?: string): void Static Inherited DisplayStyleTool Register this Tool class with the ToolRegistry.

Properties

Name Type Description
maxArgs Accessor Static ReadOnly number The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum.  
minArgs Accessor Static ReadOnly number The minimum number of arguments allowed by parseAndRun.  
toolId Static string The unique string that identifies this tool.  

Inherited properties

Name Type Inherited from Description
description Accessor Inherited ReadOnly string DisplayStyleTool Get the localized description string from this Tool's class
description Accessor Static Inherited ReadOnly string DisplayStyleTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
flyover is returned.
englishKeyin Accessor Static Inherited ReadOnly string DisplayStyleTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor Inherited ReadOnly string DisplayStyleTool Get the localized flyover string from this Tool's class
flyover Accessor Static Inherited ReadOnly string DisplayStyleTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
keyin is returned.
hidden Static Inherited boolean DisplayStyleTool If true, this Tool will not appear in the list from ToolRegistry.getToolList.
iconSpec Accessor Inherited ReadOnly string DisplayStyleTool Get the iconSpec from this Tool's class.
iconSpec Static Inherited string DisplayStyleTool The icon for this Tool.
keyin Accessor Inherited ReadOnly string DisplayStyleTool Get the localized keyin string from this Tool's class
keyin Accessor Static Inherited ReadOnly string DisplayStyleTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
namespace Static Inherited string DisplayStyleTool The namespace that provides localized strings for this Tool.
require3d Accessor Protected Inherited ReadOnly boolean DisplayStyleTool  
toolId Accessor Inherited ReadOnly string DisplayStyleTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.

Defined in

Last Updated: 14 November, 2024