applyOverrides Method
Selectively override some of these settings. Any field that is explicitly defined by the input will be overridden in these settings; any fields left undefined in the input will retain their current values in these settings. The input's ViewFlags are applied individually - only those flags that are explicitly defined will be overridden. For example, the following overrides will set the render mode to "smooth", change the background color to white, turn shadows off, and leave all other settings intact:
{
viewflags: {
renderMode: RenderMode.SmoothShade,
shadows: false,
},
backgroundColor: ColorByName.white,
}
applyOverrides(overrides: DisplayStyleSettingsProps): void
@see toOverrides to produce overrides from an existing DisplayStyleSettings.
Parameter | Type | Description |
---|---|---|
overrides | DisplayStyleSettingsProps |
Returns - void
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.