toOverrides Method
Serialize a subset of these settings to JSON, such that they can be applied to another DisplayStyleSettings to selectively override those settings.
toOverrides(options?: DisplayStyleOverridesOptions): DisplayStyleSettingsProps
@returns a JSON representation of the selected settings suitable for passing to applyOverrides.
@see applyOverrides to apply the overrides to another DisplayStyleSettings..
Parameter | Type | Description |
---|---|---|
options | DisplayStyleOverridesOptions | Specifies which settings should be serialized. By default, settings that are specific to an iModel (e.g., subcategory overrides) or iTwin (e.g., context reality models) are omitted, as are drawing aids (e.g., ACS triad and grid). |
Returns - DisplayStyleSettingsProps
a JSON representation of the selected settings suitable for passing to applyOverrides.
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.