SnowParticle Interface
Represents one particle displayed by a SnowDecorator. Particle positions are in CoordSystem.View.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
velocity | Vector2d | Current velocity, in pixels per second. | |
x | number | Make x, y, and z from ParticleProps writable. | |
y | number | y coordinate | |
z | number | z coordinate |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
rotationMatrix Inherited | Matrix3d | undefined | ParticleProps | A rotation matrix to orient the particle. |
size Inherited | number | Readonly<WritableXAndY> | ParticleProps | The size of the particle, in the collection's coordinate space. |
transparency Inherited | number | undefined | ParticleProps | The transparency with which to draw the particle as an integer in [0,255]. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.