ParticleProps Interface
Describes a particle to to add to a particle collection via addParticle. The x, y, and z coordinates represent the centroid of the particle quad in the collection's coordinate space.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
rotationMatrix | Matrix3d | undefined | A rotation matrix to orient the particle. | |
size | number | Readonly<WritableXAndY> | The size of the particle, in the collection's coordinate space. | |
transparency | number | undefined | The transparency with which to draw the particle as an integer in [0,255]. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
x Readonly Inherited | number | XYAndZ | x coordinate |
y Readonly Inherited | number | XYAndZ | y coordinate |
z Readonly Inherited | number | XYAndZ | z coordinate |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.