BasicManipulationCommandIpc Interface
Interface for a backend EditCommand command that provides basic creation and modification operations.
Extends
Methods
Name | Description | |
---|---|---|
addAllowedChannel(channelKey: string): Promise<void> | ||
deleteElements(ids: string): Promise<IModelStatus> | ||
insertGeometricElement(props: GeometricElementProps): Promise<string> | Create and insert a new geometric element. | |
insertGeometryPart(props: GeometryPartProps): Promise<string> | Create and insert a new geometry part element. | |
removeAllowedChannel(channelKey: string): Promise<void> | ||
requestElementGeometry(id: string, filter?: FlatBufferGeometryFilter): Promise<undefined | ElementGeometryInfo> | Request geometry from an existing element. | |
rotatePlacement(ids: string, matrix: Matrix3dProps, aboutCenter: boolean): Promise<IModelStatus> | ||
transformPlacement(ids: string, transform: TransformProps): Promise<IModelStatus> | ||
updateEcefLocation(ecefLocation: EcefLocationProps): Promise<void> | Update the position of the iModel on the earth. | |
updateGeometricElement(propsOrId: string | GeometricElementProps, data?: ElementGeometryBuilderParams): Promise<void> | Update an existing geometric element. | |
updateProjectExtents(extents: Range3dProps): Promise<void> | Update the project extents for the iModel. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
ping Inherited | () => Promise<{ commandId: string, version: string }> | EditCommandIpc | Identify the current EditCommand 's name and version, optionally returning additional properties that describe its state. |
Defined in
- EditorBuiltInIpc.ts Line 42
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.