FlatBufferGeometryFilter Interface
Optional criteria for requesting a GeometryStream from the backend.
Properties
Name | Type | Description | |
---|---|---|---|
accept | ElementGeometryOpcode[] | undefined | Optional array of displayable opCodes to accept | |
geometry | { curves: boolean, solids: boolean, surfaces: boolean } | undefined | Optional geometry type filter | |
maxDisplayable | number | undefined | Optional limit on number of displayable entries to accept | |
reject | ElementGeometryOpcode[] | undefined | Optional array of displayable opCodes to reject |
Defined in
- EditorBuiltInIpc.ts Line 24
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.