ElementGeometryOpcode Enumeration
Specifies the type of an entry in a geometry stream.
@see ElementGeometryDataEntry.opcode.
Members
Name | Value | Description |
---|---|---|
ArcPrimitive | Arc or ellipse (automatic simplification of a CurvePrimitive or CurveCollection) | |
BasicSymbology | Sets symbology for subsequent geometry to override SubCategory appearance | |
BRep | Boundary representation solid, sheet, or wire body as a DataProps | |
BsplineSurface | BSplineSurface3d | |
CurveCollection | CurveCollection | |
CurvePrimitive | CurvePrimitive | |
Fill | Opaque and Gradient fills. | |
Image | Small single-tile raster image as an ImageGraphic | |
LineStyleModifiers | Specifies line style overrides as a Modifier | |
Material | RenderMaterial | |
PartReference | A reference to a GeometryPart. | |
Pattern | Hatch, cross-hatch, or AreaPattern. | |
PointPrimitive | A line, line string, shape, or point string (automatic simplification of a CurvePrimitive or CurveCollection) | |
PointPrimitive2d | A 2d line, line string, shape, or point string (automatic simplification of a CurvePrimitive or CurveCollection) | |
Polyface | Polyface | |
SolidPrimitive | SolidPrimitive | |
SubGraphicRange | Local range of the next geometric primitive in the geometry stream. | |
TextString | TextString |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.