RelationshipConstraintDiagnostic<ARGS extends any[]> Class
An IDiagnostic implementation used for RelationshipConstraint diagnostics.
Extends
Methods
Name | Description | |
---|---|---|
constructor<ARGS extends any[]>(constraint: RelationshipConstraint, messageArgs: ARGS, category: DiagnosticCategoryDiagnosticCategory.Error): RelationshipConstraintDiagnostic<ARGS> | Initializes a new RelationshipConstraintDiagnostic. |
Properties
Name | Type | Description | |
---|---|---|---|
diagnosticType Accessor ReadOnly | DiagnosticType | Gets the DiagnosticType. | |
schema Accessor ReadOnly | Schema | Gets the schema where the diagnostic originated. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
category Inherited | DiagnosticCategory | BaseDiagnostic<RelationshipConstraint, ARGS> | The diagnostic category is of the type DiagnosticCategory; which is defined as an enumeration above. |
code Accessor Abstract Inherited ReadOnly | string | BaseDiagnostic<RelationshipConstraint, ARGS> | Gets the unique string identifier for the diagnostic in the format ' |
ecDefinition Inherited | RelationshipConstraint | BaseDiagnostic<RelationshipConstraint, ARGS> | The EC object to associate with the diagnostic. |
ARGS | undefined | BaseDiagnostic<RelationshipConstraint, ARGS> | The arguments used when formatting the diagnostic message. | |
string | BaseDiagnostic<RelationshipConstraint, ARGS> | Gets the message associated with the diagnostic. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.