CustomAttributeContainerDiagnostic<ARGS extends any[]> Class
An IDiagnostic implementation used for CustomAttributeContainerProps diagnostics.
Extends
Methods
Name | Description | |
---|---|---|
constructor<ARGS extends any[]>(container: CustomAttributeContainerProps, messageArgs: ARGS, category: DiagnosticCategoryDiagnosticCategory.Error): CustomAttributeContainerDiagnostic<ARGS> | Initializes a new CustomAttributeContainerDiagnostic. |
Properties
Name | Type | Description | |
---|---|---|---|
diagnosticType Accessor ReadOnly | DiagnosticType | Gets the DiagnosticType. | |
schema Accessor ReadOnly | Schema | Gets the schema where the diagnostic originated. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
category Inherited | DiagnosticCategory | BaseDiagnostic<CustomAttributeContainerProps, ARGS> | The diagnostic category is of the type DiagnosticCategory; which is defined as an enumeration above. |
code Accessor Abstract Inherited ReadOnly | string | BaseDiagnostic<CustomAttributeContainerProps, ARGS> | Gets the unique string identifier for the diagnostic in the format ' |
ecDefinition Inherited | CustomAttributeContainerProps | BaseDiagnostic<CustomAttributeContainerProps, ARGS> | The EC object to associate with the diagnostic. |
ARGS | undefined | BaseDiagnostic<CustomAttributeContainerProps, ARGS> | The arguments used when formatting the diagnostic message. | |
string | BaseDiagnostic<CustomAttributeContainerProps, ARGS> | Gets the message associated with the diagnostic. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.