constructor Method
Constructor
FormatterSpec(name: string, format: Format, conversions?: UnitConversionSpec[], persistenceUnit?: UnitProps, azimuthBaseConversion?: UnitConversionProps, revolutionConversion?: UnitConversionProps): FormatterSpec
Parameter | Type | Description |
---|---|---|
name | string | The name of a format specification. |
format | Format | Defines the output format for the quantity value. |
conversions | UnitConversionSpec[] | An array of conversion factors necessary to convert from an input unit to the units specified in the format. |
persistenceUnit | UnitProps | The unit the magnitude value is input. |
azimuthBaseConversion | UnitConversionProps | The conversion used to interpret azimuth base values. |
revolutionConversion | UnitConversionProps | The conversion used to determine a revolution value (used for bearing and azimuth). |
Returns - FormatterSpec
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.