UnitConversionSpec Interface
Interface that defines how to convert between a specific unit an another in synchronous formatting or parsing processing.
Properties
Name | Type | Description | |
---|---|---|---|
conversion | UnitConversionProps | the information necessary to convert the unit to a specific display unit | |
label | string | The default label that is used to display unit | |
name | string | Unit name that was used to locate the unit by the Unit Provider | |
parseLabels | string[] | undefined | Labels that may be used to represent the unit in a string that is to be parsed. | |
system | string | Unit system name, used to when finding preferred parse unit |
Defined in
- quantity/src/Interfaces.ts Line 45
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.