intersectRay Method
Compute the points of intersection with a ray.
intersectRay(ray: Ray3d): undefined | CurveAndSurfaceLocationDetail[]
@returns 1 or 2 points if there are intersections, undefined if no intersections
Parameter | Type | Description |
---|---|---|
ray | Ray3d | ray in space |
Returns - undefined | CurveAndSurfaceLocationDetail[]
1 or 2 points if there are intersections, undefined if no intersections
Defined in
- geometry3d/BilinearPatch.ts Line 199
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.