searchForClosestApproach MethodStatic

Search the range trees for closest approach(es) between the polylines.

searchForClosestApproach(contextA: LineString3dRangeTreeContext, contextB: LineString3dRangeTreeContext, maxDist?: number): undefined | CurveLocationDetailPair | CurveLocationDetailPair[]

@returns closest approach detail pair(s), one per context, with detail.a set to the approach distance

Parameter Type Description
contextA LineString3dRangeTreeContext first polyline context
contextB LineString3dRangeTreeContext second polyline context
maxDist number collect close approaches separated by no more than this distance. If undefined, return only the closest approach.

Returns - undefined | CurveLocationDetailPair | CurveLocationDetailPair[]

closest approach detail pair(s), one per context, with detail.a set to the approach distance

Defined in

Last Updated: 14 November, 2024