tryTransformInPlace Method
Apply transform
to the data in each channel.
tryTransformInPlace(transform: Transform): boolean
@see AuxChannelDataType for details regarding how each data type is affected by the transform.
@note This method may fail if a channel of AuxChannelDataType.Normal exists and transform.matrix
is non-invertible.
@returns true if the channels were all successfully transformed.
Parameter | Type | Description |
---|---|---|
transform | Transform |
Returns - boolean
true if the channels were all successfully transformed.
Defined in
- polyface/AuxData.ts Line 254
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.