ConvexFacetLocationDetail Class
Implementation of FacetLocationDetail
for a convex facet.
- If
edgeCount
is 3,TriangularFacetLocationDetail
is more efficient.
Extends
Methods
Name | Description | |
---|---|---|
clone(): ConvexFacetLocationDetail | Clone the instance | |
copyContentsFrom(other: ConvexFacetLocationDetail): void | Set the instance contents from the other detail. | |
getBarycentricCoordinates(facetVertices?: IndexedXYZCollection, distanceTolerance: numberGeometry.smallMetricDistance): undefined | number[] | Get the barycentric coordinates of this location, if they have been computed. | |
getColor(facetColors?: number[], facetVertices?: IndexedXYZCollection, distanceTolerance: numberGeometry.smallMetricDistance): undefined | number | Get color interpolated from facet data. | |
getNormal(facetNormals?: IndexedXYZCollection, facetVertices?: IndexedXYZCollection, distanceTolerance: numberGeometry.smallMetricDistance): undefined | Vector3d | Get normal interpolated from facet data. | |
getParam(facetParams?: IndexedXYCollection, facetVertices?: IndexedXYZCollection, distanceTolerance: numberGeometry.smallMetricDistance): undefined | Point2d | Get uv parameter interpolated from facet data. | |
invalidate(deep: booleantrue): void | Invalidate this detail. | |
create(facetIndex: number-1, edgeCount: number0, detail?: PolygonLocationDetail, result?: ConvexFacetLocationDetail): ConvexFacetLocationDetail Static | Create a detail. | |
createCapture(facetIndex: number, edgeCount: number, detail: PolygonLocationDetail): ConvexFacetLocationDetail Static | Create a detail, capturing inputs. |
Properties
Name | Type | Description | |
---|---|---|---|
isConvex Accessor ReadOnly | boolean | Whether the facet is convex. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_detail Protected Inherited | PolygonLocationDetail | NonConvexFacetLocationDetail | |
a Accessor Inherited ReadOnly | number | NonConvexFacetLocationDetail | Get the application-specific number. |
classify Accessor Inherited ReadOnly | PolygonLocation | NonConvexFacetLocationDetail | Get the code that classifies the location of the point with respect to the facet. |
closestEdge Accessor Inherited ReadOnly | { edgeParam: number, startVertexIndex: number } | NonConvexFacetLocationDetail | Get the projection of the point onto the closest facet edge. |
edgeCount Accessor Inherited ReadOnly | number | NonConvexFacetLocationDetail | Get the edge count of this facet. |
facetIndex Accessor Inherited ReadOnly | number | NonConvexFacetLocationDetail | Get the facet index. |
isInsideOrOn Accessor Inherited ReadOnly | boolean | NonConvexFacetLocationDetail | Whether the point is inside or on the polygon. |
isValid Accessor Inherited ReadOnly | boolean | NonConvexFacetLocationDetail | Whether this instance specifies a valid location. |
point Accessor Inherited ReadOnly | Point3d | NonConvexFacetLocationDetail | Get the world coordinates of the point. |
Defined in
- polyface/FacetLocationDetail.ts Line 379
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.