PolygonLocation Enumeration
Enumeration of possible locations of a point in the plane of a polygon.
Members
Name |
Value |
Description |
InsidePolygon |
|
Point is strictly inside the polygon with unknown projection. |
InsidePolygonProjectsToEdgeInterior |
|
Point is strictly inside the polygon and projects to an edge (but not a vertex). |
InsidePolygonProjectsToVertex |
|
Point is strictly inside the polygon and projects to a vertex. |
OnPolygonEdgeInterior |
|
Point is on an edge (but not a vertex). |
OnPolygonVertex |
|
Point is at a vertex. |
OutsidePolygon |
|
Point is strictly outside the polygon with unknown projection. |
OutsidePolygonProjectsToEdgeInterior |
|
Point is strictly outside the polygon and projects to an edge (but not a vertex). |
OutsidePolygonProjectsToVertex |
|
Point is strictly outside the polygon and projects to a vertex. |
Unknown |
|
No location specified. |
Defined in
Last Updated: 13 November, 2024