ClippedPolyfaceBuilders Class
A pair of PolyfaceBuilder objects, for use by clippers that emit inside and outside parts. *
Methods
Name | Description | |
---|---|---|
claimPolyface(selector: "0" | "1", fixup: boolean, tolerance: numberGeometry.smallMetricDistance): undefined | IndexedPolyface | Return the computed facets from the selected builder. | |
create(keepInside: booleantrue, keepOutside: booleanfalse, buildSideFaces: booleanfalse): ClippedPolyfaceBuilders Static | Static constructor with default options for the builders. |
Properties
Name | Type | Description | |
---|---|---|---|
buildClosureFaces | boolean | undefined | request to construct cut faces | |
builderA | PolyfaceBuilder | undefined | An available builder. | |
builderB | PolyfaceBuilder | undefined | An available builder. |
Defined in
- polyface/PolyfaceClip.ts Line 52
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.