applyRigidPartOfTransform MethodProtected
- If transformA is rigid with uniform scale, apply the rigid part of transformA to the localToWorld transform and return the scale and rigid separation.
- If not rigid, do nothing and return undefined.
- Also apply the scale factor to the designProperties.
applyRigidPartOfTransform(transformA: Transform): undefined | { rigidAxes: Matrix3d, scale: number }
Parameter | Type | Description |
---|---|---|
transformA | Transform |
Returns - undefined | { rigidAxes: Matrix3d, scale: number }
Defined in
- curve/spiral/TransitionSpiral3d.ts Line 179
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.