create MethodStatic
Construct options with optional defaults.
create(method: EllipticalArcSampleMethodEllipticalArcSampleMethod.AdaptiveSubdivision, numSamplesInQuadrant: number4, maxError: number..., remapFunction: FractionMapper..., forcePath: booleanfalse): EllipticalArcApproximationOptions
Parameter | Type | Description |
---|---|---|
method | EllipticalArcSampleMethod | sample method, default AdaptiveSubdivision. |
numSamplesInQuadrant | number | samples in each full quadrant for interpolation methods, default 4. |
maxError | number | positive maximum distance to ellipse for the subdivision method, default 1cm. |
remapFunction | FractionMapper | optional callback to remap fraction space for NonUniformCurvature, default quadratic. For best results, this function should be a bijection. |
forcePath | boolean | whether to return a Path instead of a Loop when approximating a full elliptical arc, default false. |
Returns - EllipticalArcApproximationOptions
Defined in
- curve/Arc3d.ts Line 141
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.