EllipticalArcApproximationOptions Class

Options for generating samples for the construction of an approximation to an elliptical arc.

Methods

Name Description
clone(): EllipticalArcApproximationOptions Clone the options.  
create(method: EllipticalArcSampleMethodEllipticalArcSampleMethod.AdaptiveSubdivision, numSamplesInQuadrant: number4, maxError: number..., remapFunction: FractionMapper..., forcePath: booleanfalse): EllipticalArcApproximationOptions Static Construct options with optional defaults.  

Properties

Name Type Description
defaultMaxError Static number Default error tolerance.  
forcePath Accessor boolean Whether to return a Path instead of a Loop when approximating a full (closed) ellipse.  
maxError Accessor number Maximum distance (in meters) of the computed approximation to the elliptical arc.  
numSamplesInQuadrant Accessor number Number of samples to return in each full quadrant, including endpoint(s).  
remapFunction Accessor FractionMapper Callback function to remap fraction space to fraction space.  
sampleMethod Accessor EllipticalArcSampleMethod Method used to sample the elliptical arc.  

Defined in

Last Updated: 14 November, 2024