EllipticalArcSampleMethod Enumeration
Enumeration of methods used to sample an elliptical arc in constructCircularArcChainApproximation.
- Because ellipses have two axes of symmetry, samples are computed for one quadrant and reflected across each axis to the other quadrants. Any samples that fall outside the arc sweep are filtered out.
Members
Name | Value | Description |
---|---|---|
AdaptiveSubdivision | Generate samples by subdividing parameter space until the approximation has less than a given max distance to the elliptical arc. |
|
NonUniformCurvature | Generate n samples interpolated between the min and max curvatures of a full ellipse quadrant, using a FractionMapper callback to generate the interpolation weights. |
|
UniformCurvature | Generate n samples uniformly interpolated between the min and max curvatures of a full ellipse quadrant. | |
UniformParameter | Generate n samples uniformly interpolated between the min and max parameters of a full ellipse quadrant. |
Defined in
- curve/Arc3d.ts Line 80
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.