closestApproachRay3dRay3d MethodStatic
Determine if two rays intersect, or are fully overlapped, or parallel but not coincident, or skew.
- Return a CurveLocationDetailPair which contains fraction and point on each ray and has
annotation (in member
approachType
) indicating one of these relationships:- CurveCurveApproachType.Intersection -- the rays have a simple intersection, at fractions indicated in detailA and detailB
- CurveCurveApproachType.PerpendicularChord -- there is pair of where the rays have closest approach. The rays are skew in space.
- CurveCurveApproachType.CoincidentGeometry -- the rays are the same unbounded line in space. The fractions and points are a representative single common point.
- CurveCurveApproachType.Parallel -- the rays are parallel (and not coincident). The two points are at the minimum distance
closestApproachRay3dRay3d(rayA: Ray3d, rayB: Ray3d): CurveLocationDetailPair
Parameter | Type | Description |
---|---|---|
rayA | Ray3d | |
rayB | Ray3d |
Returns - CurveLocationDetailPair
Defined in
- geometry3d/Ray3d.ts Line 503
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.