PolylineOps Class
PolylineOps is a collection of static methods operating on polylines.
Methods
Name | Description | |
---|---|---|
constructor(): PolylineOps | ||
addClosurePoint(data: Point3d[] | Point3d[][]): void Static | Add closure points to a polyline or array of polylines | |
closestApproach(pointsA: IndexedXYZCollection | Point3d[], extendA: VariantCurveExtendParameter, pointsB: IndexedXYZCollection | Point3d[], extendB: VariantCurveExtendParameter, dMax: numberNumber.MAX_VALUE, result?: CurveLocationDetailPair): undefined | CurveLocationDetailPair Static | Find smallest distance between polylines. | |
compressByChordError(source: Point3d[], chordTolerance: number): Point3d[] Static | Return a simplified subset of given points. | |
compressByPerpendicularDistance(source: Point3d[], maxDistance: number, numPass: number2): Point3d[] Static | Return a simplified subset of given points, omitting points if close to the edge between neighboring points before and after | |
compressDanglers(source: Point3d[], closed: booleanfalse, tolerance: numberGeometry.smallMetricDistance): Point3d[] Static | Return a simplified subset of given points, omitting points on "danglers" that depart and return on a single path. | |
compressShortEdges(source: IndexedXYZCollection | Point3d[], maxEdgeLength: number): Point3d[] Static | Return a simplified subset of given points, omitting points if very close to their neighbors. | |
compressSmallTriangles(source: Point3d[], maxTriangleArea: number): Point3d[] Static | Return a simplified subset of given points, omitting points of the triangle with adjacent points is small. | |
createBisectorPlanesForDistinctPoints(centerline: IndexedXYZCollection | Point3d[], wrapIfPhysicallyClosed: booleanfalse): undefined | Plane3dByOriginAndUnitNormal[] Static | Create an array of planes. | |
edgeLengthRange(points: Point3d[]): Range1d Static | Return a Range1d with the shortest and longest edge lengths of the polyline. | |
removeClosurePoint(data: Point3d[] | Point3d[][]): void Static | Remove closure points of a polyline or array of polylines |
Defined in
- geometry3d/PolylineOps.ts Line 27
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.