factorRigidSkew Method
Compute the factorization M = R*G, where R is rigid (a rotation) and G is whatever is left over (skew, scale, mirror, etc).
- The rotation is computed from the instance by passing
axisOrder
into createRigidFromMatrix3d.
factorRigidSkew(rotation: Matrix3d, skew: Matrix3d, axisOrder: AxisOrderAxisOrder.XYZ): boolean
@returns whether createRigidFromMatrix3d succeeded; if not, rotation
is set to the identity, and skew
is
set to this instance.
Parameter | Type | Description |
---|---|---|
rotation | Matrix3d | the rigid factor R |
skew | Matrix3d | the non-rotation factor G = R^t * M (since R transposed is its inverse) |
axisOrder | AxisOrder | optional cross product ordering for computing R |
Returns - boolean
whether createRigidFromMatrix3d succeeded; if not, rotation
is set to the identity, and skew
is
set to this instance.
Defined in
- geometry3d/Matrix3d.ts Line 2802
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.