createShuffledColumns MethodStatic
Create a matrix from column vectors, shuffled into place per axisOrder
- For example, if axisOrder = XYZ then it returns [vectorU, vectorV, vectorW]
- Another example, if axisOrder = YZX then it returns [vectorW, vectorU, vectorV] because Y is at index 0 so vectorU goes to the column Y (column 2), Z is at index 1 so vectorV goes to the column Z (column 3), and X is at index 2 so vectorW goes to the column X (column 1)
createShuffledColumns(vectorU: Vector3d, vectorV: Vector3d, vectorW: Vector3d, axisOrder: AxisOrder, result?: Matrix3d): Matrix3d
Parameter | Type | Description |
---|---|---|
vectorU | Vector3d | |
vectorV | Vector3d | |
vectorW | Vector3d | |
axisOrder | AxisOrder | |
result | Matrix3d |
Returns - Matrix3d
Defined in
- geometry3d/Matrix3d.ts Line 686
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.