createRigidHeadsUp MethodStatic
Construct a rigid matrix (orthogonal matrix with +1 determinant) using vectorA and its 2 perpendicular.
- If axisOrder is not passed then
AxisOrder = AxisOrder.ZXY
is used as default. - This function internally uses createPerpendicularVectorFavorXYPlane and createRigidFromColumns.
- If you want to rotate a given plane (which contains (0,0,0)) to the xy-plane, pass the normal vector of your plane into createRigidHeadsUp. The transpose of the returned Matrix3d can be used to rotate your plane to the xy-plane. If plane does not contain (0,0,0) then the plane is rotated to a plane parallel to the xy-plane.
- Visualization can be found at https://www.itwinjs.org/sandbox/SaeedTorabi/2PerpendicularVectorsTo1Vector
createRigidHeadsUp(vectorA: Vector3d, axisOrder: AxisOrderAxisOrder.ZXY, result?: Matrix3d): Matrix3d
Parameter | Type | Description |
---|---|---|
vectorA | Vector3d | |
axisOrder | AxisOrder | |
result | Matrix3d |
Returns - Matrix3d
Defined in
- geometry3d/Matrix3d.ts Line 731
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.