createRigidFromColumns MethodStatic
Create a new orthogonal matrix (perpendicular columns, unit length, transpose is inverse).
vectorA1 = Normalized vectorA
is placed in the column specified by first letter in the AxisOrder name.- Normalized
vectorC1 = vectorA1 cross vectorB
is placed in the column specified by third letter in the AxisOrder name. - Normalized
vectorC1 cross vectorA
is placed in the column specified by second letter in the AxisOrder name. - This function internally uses createShuffledColumns.
createRigidFromColumns(vectorA: Vector3d, vectorB: Vector3d, axisOrder: AxisOrder, result?: Matrix3d): undefined | Matrix3d
Parameter | Type | Description |
---|---|---|
vectorA | Vector3d | |
vectorB | Vector3d | |
axisOrder | AxisOrder | |
result | Matrix3d |
Returns - undefined | Matrix3d
Defined in
- geometry3d/Matrix3d.ts Line 705
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.