IndexedXYZCollectionPolygonOps Class
IndexedXYZCollectionPolygonOps
class contains static methods for typical operations on polygons carried as IndexedXYZCollection
Methods
Name | Description | |
---|---|---|
constructor(): IndexedXYZCollectionPolygonOps | ||
clipConvexPolygonInPlace(plane: PlaneAltitudeEvaluator, xyz: GrowableXYZArray, work: GrowableXYZArray, keepPositive: booleantrue, tolerance: numberGeometry.smallMetricDistance): number Static | Clip a polygon to one side of a plane. | |
intersectRangeConvexPolygonInPlace(range: Range3d, xyz: GrowableXYZArray): undefined | GrowableXYZArray Static | Return the intersection of the plane with a range cube. | |
polygonPlaneCrossings(plane: PlaneAltitudeEvaluator, xyz: IndexedXYZCollection, crossings: Point3d[]): void Static | Return an array containing | |
splitConvexPolygonInsideOutsidePlane(plane: PlaneAltitudeEvaluator, xyz: IndexedXYZCollection, xyzPositive: IndexedReadWriteXYZCollection, xyzNegative: IndexedReadWriteXYZCollection, altitudeRange: Range1d): void Static | Split a (convex) polygon into 2 parts based on altitude evaluations. |
Defined in
- geometry3d/PolygonOps.ts Line 1359
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.