intersectRay Method
Return intersections of the ray and surface.
- uv values in the intersections are in radians unless
convertIntersectionRadiansToFractions
is true requesting conversion to patch fractions.
intersectRay(ray: Ray3d, restrictToPatch: boolean, convertIntersectionRadiansToFractions: booleanfalse): CurveAndSurfaceLocationDetail[]
Parameter | Type | Description |
---|---|---|
ray | Ray3d | |
restrictToPatch | boolean | |
convertIntersectionRadiansToFractions | boolean |
Returns - CurveAndSurfaceLocationDetail[]
Defined in
- geometry3d/Ellipsoid.ts Line 820
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.