createBlock MethodStatic
Create a ClipShape that exists as a 3 dimensional box of the range given. Optionally choose to also store this shape's zLow and zHigh members from the range through the use of a RangePlaneBitMask.
createBlock(extremities: Range3d, clipMask: ClipMaskXYZRangePlanes, isMask: booleanfalse, invisible: booleanfalse, transform?: Transform, result?: ClipShape): ClipShape
Parameter | Type | Description |
---|---|---|
extremities | Range3d | |
clipMask | ClipMaskXYZRangePlanes | |
isMask | boolean | |
invisible | boolean | |
transform | Transform | |
result | ClipShape |
Returns - ClipShape
Defined in
- clipping/ClipPrimitive.ts Line 539
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.