BSplineSurface3dQuery Interface
Interface for methods supported by both regular (xyz) and weighted (xyzw) bspline surfaces.
Implemented by
Methods
Name | Description | |
---|---|---|
clone(): BSplineSurface3dQuery | clone the surface | |
cloneTransformed(transform: Transform): BSplineSurface3dQuery | clone and transform | |
degreeUV(select: UVSelect): number | Return the degree in in selected direction (0 for u, 1 for v) | |
extendRange(rangeToExtend: Range3d, transform?: Transform): void | Extend rangeToExtend so this surface is included. |
|
fractionToPoint(uFraction: number, vFraction: number): Point3d | Evaluate xyz coordinates at fractional parameter u,v | |
fractionToRigidFrame(uFraction: number, vFraction: number, result?: Transform): undefined | Transform | Evaluate a rigid frame at fractional parameter u,v | |
getPointGridJSON(): PackedPointGrid | Return control points json arrays. | |
isAlmostEqual(other: any): boolean | test for nearly equality with other |
|
isClosable(select: UVSelect): boolean | ask if the u or v direction could be converted to periodic form | |
isInPlane(plane: Plane3dByOriginAndUnitNormal): boolean | Ask if the entire surface is within a plane. | |
isSameGeometryClass(other: any): boolean | Test if this and other are the same geometry class. |
|
knotToPoint(uKnot: number, vKnot: number): Point3d | Evaluate xyz coordinates at knot values (uKnot, vKnot) | |
numPolesTotal(): number | return the total number of poles (product of u,v counts) | |
numPolesUV(select: UVSelect): number | Return the number of poles in selected direction (0 for u, 1 for v) | |
numSpanUV(select: UVSelect): number | Return the number of bezier spans in selected direction (0 for u, 1 for v) | |
numberToUVSelect(value: number): UVSelect | turn a numeric variable into a UVSelect (strict 0 or 1). | |
orderUV(select: UVSelect): number | Return the order in in selected direction (0 for u, 1 for v) | |
poleStepUV(select: UVSelect): number | Return the step between adjacent poles in selected direction (0 for u, 1 for v) | |
reverseInPlace(select: UVSelect): void | Reverse one of the parameterization directions. | |
tryTransformInPlace(transform: Transform): boolean | apply a transform to the surface |
Defined in
- bspline/BSplineSurface.ts Line 84
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.