appendPlaneIntersectionPoints Method
Implement CurvePrimitive.appendPlaneIntersections
appendPlaneIntersectionPoints(plane: PlaneAltitudeEvaluator, result: CurveLocationDetail[]): number
@returns number of intersections appended to the array.
Parameter | Type | Description |
---|---|---|
plane | PlaneAltitudeEvaluator | A plane (e.g. specific type Plane3dByOriginAndUnitNormal or Point4d) |
result | CurveLocationDetail[] | growing array of plane intersections |
Returns - number
number of intersections appended to the array.
Defined in
- bspline/BSplineCurve.ts Line 316
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.