zoom Method
Zoom the view by a scale factor, placing the new center at the given point (world coordinates).
zoom(newCenter: Point3d, factor: number, options?: ViewChangeOptions & MarginOptions & OnViewExtentsError): ViewStatus
Parameter | Type | Description |
---|---|---|
newCenter | Point3d | The new center point of the view, in world coordinates. If undefined, use current center. |
factor | number | the zoom factor. |
options | ViewChangeOptions & MarginOptions & OnViewExtentsError | options for behavior of view change |
Returns - ViewStatus
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.