ViewStatus Enumeration
Describes the result of a viewing operation such as those exposed by ViewState and Viewport.
Members
Name |
Value |
Description |
AlreadyAttached |
|
|
DegenerateGeometry |
|
|
DrawFailure |
|
|
HeightBelowTransition |
|
|
InvalidDirection |
|
|
InvalidLens |
|
|
InvalidTargetPoint |
|
|
InvalidUpVector |
|
|
InvalidViewport |
|
|
InvalidWindow |
|
|
MaxDisplayDepth |
|
|
MaxWindow |
|
|
MaxZoom |
|
|
MinWindow |
|
|
ModelNotFound |
|
|
NotAttached |
|
|
NotCameraView |
|
|
NotEllipsoidGlobeMode |
|
|
NotGeolocated |
|
|
NotOrthographicView |
|
|
NoTransitionRequired |
|
|
NotResized |
|
|
Success |
|
|
ViewNotInitialized |
|
|
Defined in
Last Updated: 14 November, 2024