ViewChangeOptions Interface
Options that control how operations that change a viewport behave.
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
animationFinishedCallback(didComplete: boolean): void Optional Inherited | ViewAnimationOptions | Invoked when the animator is finished. |
Properties
Name | Type | Description | |
---|---|---|---|
animateFrustumChange | boolean | undefined | Whether the change should be animated or not. | |
globalAlignment | GlobalAlignmentOptions | undefined | If defined the controls how the view will be aligned with the globe | |
noSaveInUndo | boolean | undefined | Whether to save the result of this change into the view undo stack. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
animationTime Inherited | number | undefined | ViewAnimationOptions | Amount of time for animation, in milliseconds. |
cancelOnAbort Inherited | boolean | undefined | ViewAnimationOptions | if animation is aborted, don't move to end, leave at current point instead. |
easingFunction Inherited | EasingFunction | undefined | ViewAnimationOptions | easing function for animation. |
onExtentsError Inherited | (status: ViewStatus) => ViewStatus | undefined | OnViewExtentsError | Function to be called when the extents are adjusted due to a limits error (view too larger or too small) |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.