TwoWayViewportFrustumSync Class
Forms a bidirectional connection between two Viewports such that the Frustums of each are synchronized with one another. For example, zooming out in one viewport will zoom out by the same distance in the other viewport. No other aspects of the viewports are synchronized - they may have entirely different display styles, category/model selectors, etc.
@see - TwoWayViewportSync to synchronize all aspects of the viewports.
- connectViewportFrusta to synchronize the frusta of more than two viewports.
Extends
Methods
Name | Description | |
---|---|---|
constructor(): TwoWayViewportFrustumSync | ||
connectViewports(source: Viewport, target: Viewport): void Protected | Sets up the initial connection between two viewports by applying source 's frustum to target . |
|
syncViewports(source: Viewport, target: Viewport): void Protected | Synchronizes the two viewports by applying source 's frustum to target . |
Inherited methods
Name | Inherited from | Description |
---|---|---|
connect(viewport1: Viewport, viewport2: Viewport): void Inherited | TwoWayViewportSync | Establish the connection between two Viewports. |
disconnect(): void Inherited | TwoWayViewportSync | Remove the connection between the two views. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_disconnect Protected Readonly Inherited | VoidFunction[] | TwoWayViewportSync |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.